Job Board Blog Finding a new job just got easier

INSTALLING CISCO ASDM 6.3 ON WINDOWS 10 FAILS WITH JAVA ERROR: "JAVA RUNTIME ENVIRONMENT IS NOT INSTALLED ON THIS MACHINE."

Cisco ASDM-IDM Launcher Information

Java Runtime Environment is not installed on this machine. Please install Java Runtime Environment from http://java.sun.com/javase/downloads/

undefined

I tried installing several versions of 32 and 64 bit Java and running in compatibility mode. Basically, i settled on using the Java Web Start version, that can be found on the main web portal page. Or it can be launched by using the following link (of course insert your IP address in the first part).

Try to download this jre-6u33-windows-i586 for install on your computer.

Cisco Asa 5510 Firewall ASDM Login

For access to ASDM, here are the primary commands you need on ASA-

1) Set the ASDM image.

Assuming that you have asdm image file on disk of ASA saved as asdm.bin, you need to configure this commands-

asdm image disk0:/asdm.bin

2) Enable HTTP server-

http server enable

3) Allow hosts to connect to HTTP server-

http 0 0 inside

(to allow everyone on inside interface)

http 0 0 outside

(to allow everyone on outside interface)

By default, for user authentication, leave username field blank and enter your enable password. If you have not set any enable password yet, you may leave the password field blank too.

To set the enable password, you can use following command-

enable password

Password Recovery Procedure

To recover passwords for the ASA, perform the following steps:

Step 1 Connect to the ASA console port according to the instructions in "Accessing the Command-Line Interface" section.

Step 2 Power off the ASA, and then power it on.

Step 3 After startup, press the Escape key when you are prompted to enter ROMMON mode.

Step 4 To update the configuration register value, enter the following command:

  • rommon #1> confreg 0x41

Update Config Register (0x41) in NVRAM...

Step 5 To set the ASA to ignore the startup configuration, enter the following command:

  •  rommon #1> confreg

The ASA displays the current configuration register value, and asks whether you want to change it:

  • Current Configuration Register: 0x00000041

Configuration Summary:

  • boot default image from Flash
  • ignore system configuration
  • Do you wish to change this configuration? y/n [n]: y

Step 6 Record the current configuration register value, so you can restore it later.

Step 7 At the prompt, enter Y to change the value.

The ASA prompts you for new values.

Step 8 Accept the default values for all settings. At the prompt, enter Y.

Step 9 Reload the ASA by entering the following command:

  • rommon #2> boot
    Launching BootLoader...
    Boot configuration file contains 1 entry.
    Loading disk0:/asa800-226-k8.bin... Booting...Loading...

The ASA loads the default configuration instead of the startup configuration.

Step 10 Access the privileged EXEC mode by entering the following command:

  • hostname> enable

Step 11 When prompted for the password, press Enter.

The password is blank.

Step 12 Load the startup configuration by entering the following command:

  •  hostname# copy startup-config running-config

Step 13 Access the global configuration mode by entering the following command:

  • hostname# configure terminal

Step 14 Change the passwords, as required, in the default configuration by entering the following commands:

  • hostname(config)# password password
  • hostname(config)# enable password password
  • hostname(config)# username name password password

Step 15 Load the default configuration by entering the following command:

  •  hostname(config)# no config-register 

The default configuration register value is 0x1.

Step 16 Save the new passwords to the startup configuration by entering the following command:

  • hostname(config)# copy running-config startup-config

 

Cisco ASA 5505 Configuration: 6-Steps Basic Tutorial

The Cisco ASA 5505 Firewall is the smallest model in the new 5500 Cisco series of hardware appliances. Although this model is suitable for small businesses, branch offices or even home use, its firewall security capabilities are the same as the biggest models (5510, 5520, 5540 etc). The Adaptive Security technology of the ASA firewalls offers solid and reliable firewall protection, advanced application-aware security, denial of service attack protection and much more. Moreover, the performance of the ASA 5505 appliance supports 150Mbps firewall throughput and 4000 firewall connections per second, which is more than enough for small networks. In this article, I will explain the basic Cisco ASA 5505 configuration for connecting a small network to the Internet.

We assume that our ISP has assigned us a static public IP address (e.g 200.200.200.1 as an example) and that our internal network range is 192.168.1.0/24. We will use Port Address Translation (PAT) to translate our internal IP addresses to the public address of the outside interface. The difference of the 5505 model from the bigger ASA models is that it has an 8-port 10/100 switch which acts as Layer 2 only. That is, you can not configure the physical ports as Layer 3 ports, rather you have to create interface VLANs and assign the Layer 2 interfaces in each VLAN. By default, interface Ethernet0/0 is assigned to VLAN 2 and it’s the outside interface (the one which connects to the Internet), and the other 7 interfaces (Ethernet0/1 to 0/7) are assigned by default to VLAN 1 and are used for connecting to the internal network. Let’s see the basic configuration setup of the most important steps that you need to configure.

Cisco ASA 5505 configuration
Let’s now have a look at the Cisco ASA 5505 configuration, in a step by step fashion.

Step1: Configure the internal interface vlan

  • ASA5505(config)# interface Vlan 1
  • ASA5505(config-if)# nameif inside
  • ASA5505(config-if)# security-level 100
  • ASA5505(config-if)# ip address 192.168.1.1 255.255.255.0
  • ASA5505(config-if)# no shut

Step 2: Configure the external interface vlan (connected to Internet)

  • ASA5505(config)# interface Vlan 2
  • ASA5505(config-if)# nameif outside
  • ASA5505(config-if)# security-level 0
  • ASA5505(config-if)# ip address 200.200.200.1 255.255.255.0
  • ASA5505(config-if)# no shut

Step 3: Assign Ethernet 0/0 to Vlan 2

  • ASA5505(config)# interface Ethernet0/0
  • ASA5505(config-if)# switchport access vlan 2
  • ASA5505(config-if)# no shut

Step 4: Enable the rest interfaces with no shut

  • ASA5505(config)# interface Ethernet0/1
  • ASA5505(config-if)# no shut

Do the same for Ethernet0/1 to 0/7.

 

Step 5: Configure PAT on the outside interface

  • ASA5505(config)# global (outside) 1 interface
  • ASA5505(config)# nat (inside) 1 0.0.0.0 0.0.0.0

UPDATE for ASA Version 8.3 and later (including ASA versions 9.x)

From March 2010, Cisco announced the new Cisco ASA software version 8.3. This version introduced several important configuration changes, especially on the NAT/PAT mechanism. The “global” command is no longer supported. NAT (static and dynamic) and PAT are configured under network objects. The PAT configuration below is for ASA 8.3 and later:

  • object network obj_any
  • subnet 0.0.0.0 0.0.0.0
  • nat (inside,outside) dynamic interface

The above commands will accomplish the same task as the “global” and “nat” commands we had in versions prior to 8.3.

 

Step 6: Configure default route
Default route towards the ISP (assume default gateway is 200.200.200.2)

  • ASA5505(config)# route outside 0.0.0.0 0.0.0.0 200.200.200.2 1

The above steps are the absolutely necessary steps you need to configure for making the appliance operational. Of course there are much more configuration details that you need to implement in order to enhance the security and functionality of your appliance, such as Access Control Lists, Static NAT, DHCP, DMZ zones, authentication etc.

 

How to Improve Your Website's SEO

Search engine optimization can be a very intimidating task to tackle. There are many myths about SEO, and the rules seem to change by the day, but if it is approached with the right mindset the result will be very rewarding. Before you take on the task of improving your SEO it is best to understand it.


SEO can be divided into two key categories, Content and Page Authority

CONTENT TYPES

Content, or "on page SEO" includes the following components:

  • Keywords
  • Page content
  • Page titles
  • URLs
  • Metadata

PAGE AUTHORITY

Page Authority, or 'off page SEO' includes several elements, here are a few:

  • Quality websites linking to your website
  • Page sharing, interaction, and popularity on social sites

How to Improve content for SEO

  • KEYWORDS

Keywords are a core piece of the SEO puzzle. Before writing page content or meta data you need to develop a keyword strategy. Develop a list of keywords related to your company and industry that you would like to be associated with and you know people will search for.

  • Content, Page Titles
  • Develop page content, page titles, metadata, and URLs around the keywords
    You want every page of your website to rank the best it can for a keyword. Not only do you need to write valuable and informative content associated with the keyword, but you also need to include the keyword in the page title, meta description, and URL. Make sure you're following a quality content strategy; no keyword stuffing!
  • Meta descriptions

Meta descriptions are often overlooked or done incorrectly. Make sure your Meta descriptions are 150 to 160 characters in length. When a Meta description appears as a snippet on Google only the first 160 characters are displayed. Don't forget to make your Meta description enticing to the person searching on Google!

IMPROVE PAGE AUTHORITY

  • Increase your number of inbound links

The number of websites that link to a page or domain is a measure of trust. The more links you get, the more valuable your content is deemed to be by search engines. These links must be quality though. Multiple links to the same page, coming from unrelated or untrusted sources, will only hurt your SEO. A great way to get quality inbound links is to write guest blogs for other websites.

  • Develop a social media strategy

Interaction and popularity on social media sites has become one of the many components to SEO. Develop a strategy around sharing valuable content with your followers. Include your own content, along with informative content from other sources.

Don't forget, Google's algorithm is complex and frequently changing, it is important to stay informed about changes that may affect your SEO.

Keep coming back! More SEO tips are on their way!

 

 

 

 

 

The Misunderstood Meta Description

The meta description is an often misunderstood piece of the digital marketing puzzle. You know it as that snippet of text which is displayed below the page title in search engine results, and with links shared on social media sites. Think of it as a preview of coming attractions. The true purpose of a meta description is to entice users to click through to a page. Meta descriptions should provide users with content to let them know a little bit more about the page and help them decide if it is what they are looking for.

The truth is meta descriptions do not have a pure SEO value or effect on search engine rankings. If a page does not have a meta description the search engine will choose content from the page to display as the snippet of content. This gives the search engine control over how your brand is portrayed. By creating your own meta description, you control the branding of your content. ;The description never appears on the website itself, only in the code.

Tips for writing effective meta descriptions

  • Length - Use a maximum of 155 characters. If your meta description is longer than that characters may get cut off by both search engines and social media sites.
  • Specific and Meaningful - Your meta description should be concise and specific, telling the user exactly what your page is offering. The description should read as a meaningful call to action, enticing users to read further.
  • Keywords - Keywords are important in meta descriptions, but avoid keyword stuffing. Use keywords that relate specifically to the page and make sure they flow well within the description. Terms that are being searched will be highlighted in bold text in the meta descriptions on the search engine results page. You want these keywords to stand out from your competitors.
  • Uniqueness - Each page on your site should have a unique meta description. If multiple pages have the same meta description then your goal of enticing the reader to click ahead is not being realized. If you have several similar pages then you should create a formula in which slight, yet relevant changes can be made to highlight the page differences.

A good movie trailer will make you want to see the film by teasing you with some information about the movie, but won 't give too much away. That 's the same secret to writing a meta description.

 

 

 

 

Home ← Older posts